GC-Flitterkill

+Clients
  • Content count

    407
  • Joined

  • Last visited


About GC-Flitterkill

Recent Profile Visitors


14,839 profile views

GC-Flitterkill's Activity

  1. GC-Flitterkill added a post in a topic: Is there a place to set the number of topics per page displayed?   

    For topic view we can set the number of posts per page. That is there under community-forums-settings.
    I don't see a place to set the number of topics per page in forum view though. Is it just locked in at 25 or something?
  2. GC-Flitterkill added a bug in IPS4 Bug Tracker   

    [Beta 4a] Return to forum link from topic view is just alphanumeric code
    Localhost install so can't provide access. It was fine and then a few days ago it changed to this. The link still works though.

    At least I think it was normal before...
    • 0 replies
    • 0 views
  3. GC-Flitterkill added a post in a topic: Underlines in gallery   

    If you upload a file that has no spaces in the name you get:
    filename.jpg
    You can then change that to whatever of course like:
    This is my uploaded file
     
    Both of the above work fine for searching, etc.
     
    If you upload a file that has spaces in the name such as :
    file name.jpg
    It will appear in the title as:
    file_name.jpg
    There's your underscore in place of the space. You can of course edit it if you wanted to right then and there back to:
    file name.jpg
    What's probably happening is the original uploaded files need to have the spaces replaced for easier file management and parsing within the system. You *can* change this stuff in the title to whatever you want but on image upload it's pre-populating the title field with the underscored version of the file name. That might be able to be changed but I wouldn't hold my breath for it, at least not for 4.0. Maybe 4.1? Maybe...
  4. GC-Flitterkill added a post in a topic: Any IPS or Dev answer where the forum desc. lives in the DB?   

    Wow. I would have never have thought to look that closely there. Thanks!
  5. GC-Flitterkill added a post in a topic: Any IPS or Dev answer where the forum desc. lives in the DB?   

    I, for the life of me, cannot find where a forum description is stored in forums.forums - assuming that is where it is. I've rolled through nearly all the other db fields throughout the entire suite and can't seem to find it. Same for rules, though I do see the rules toggle in forums.forums. Note that I can see how to call this stuff in the templates but I want to know where it lives in the db.
    Also learned the hard way that the forum description is a full html aware field, including images, embeds, etc. Didn't expect this level of functionality there.
    Thanks
  6. GC-Flitterkill added a bug in IPS4 Bug Tracker   

    [Beta4a] Commerce - two ACP skin/language errors
    Under payment settings two of the language bits are not carrying over onto the menu. The last two choices (on the right) display as transaction_review and notification_copies respectively bypassing existing (?) language keys. When you chose those menu items the contents within appear to be functional however the language keys there are also missing and you see stuff like nexus_revw_sa_on and so on .
    Also, when attempting to add a product under a group, under the pricing tab every section under the discounts area has a misapplied grabby thing - like the movable widgets - in the top left corner. This both breaks the formatting and naturally grabbing these things and moving them around the screen does nothing as the sections snap back to their normal place automatically.
    This is a fresh install of 4a  - no existing posts, data, etc.
    • 0 replies
    • 0 views
  7. GC-Flitterkill added a post in a topic: Commerce cover photo request   

    Product groups in Commerce can have a cover photo applied which is great but there are no methods for re-positioning the photo so you are stuck with whatever is in the middle of the image as the cover photo image. A hack around it would be to upload an image roughly in the aspect ratio of the displayed version but with re-positioning as a feature already existing in the suite maybe we can get some here?
  8. GC-Flitterkill added a bug in IPS4 Bug Tracker   

    [Beta4a] Commerce cannot add product
    Fresh install, no prior items.
    group created successfully.
    Upon trying to save physical item:
    Fatal error : Access to undeclared static property: IPS\nexus\Package::$packageDatabaseColumns in  C:\wamp\www\ips_6fc39\applications\nexus\sources\Package\Package.php  on line  156
    That line is the $packageDatabaseCollumns line in the following:
    $secondaryTable = array();
            foreach ( $this->changed as $k => $v )
            {
                if ( in_array( "p_{$k}", static::$packageDatabaseColumns ) )
                {
                    $secondaryTable[ "p_{$k}" ] = $v;
                    unset( $this->changed[ $k ] );
                }
                elseif ( !in_array( "p_{$k}", array( 'p_id', 'p_name', 'p_seo_name', 'p_desc', 'p_group', 'p_stock', 'p_reg', 'p_store', 'p_member_groups', 'p_allow_upgrading', 'p_upgrade_charge', 'p_allow_downgrading', 'p_downgrade_refund', 'p_base_price', 'p_tax', 'p_renewal_days', 'p_primary_group', 'p_secondary_group', 'p_return_primary', 'p_return_secondary', 'p_position', 'p_associable', 'p_force_assoc', 'p_assoc_error', 'p_discounts', 'p_page', 'p_support', 'p_support_department', 'p_support_severity', 'p_featured', 'p_upsell', 'p_notify', 'p_type', 'p_custom', 'p_reviewable', 'p_review_moderate', 'p_image', 'p_methods', 'p_renew_options', 'p_group_renewals', 'p_rebuild_thumb', 'p_renewal_days_advance', 'p_date_added', 'p_reviews', 'p_rating' ) ) )
                {
                    unset( $this->changed[ $k ] );
                }
            }
    • 0 replies
    • 0 views
  9. GC-Flitterkill added a bug in IPS4 Bug Tracker   

    [Beta4a] Commerce Support section EX0
    Fresh install of B4a, no posts, nothing. Clicking through the apps on the front end. Store comes up fine. Support gives the something went wrong EX0 error page.
    Referenced here in the forums as well.  http://community.invisionpower.com/topic/405323-support-button/
     
    • 0 replies
    • 0 views
  10. GC-Flitterkill added a post in a topic: Datastore on WAMP   

    I'm not familiar with pathing using WAMP.
    Looking in the ACP under system-advanced-datastore I see the location listed as C:\wamp\www\ips_037cb/datastore 
    Is that last forward slash kosher? I had to backtrack the zend call in php.ini for the ioncube loader when I had the slashes going the wrong way - just want to be sure any other errors I have going on with the upgrade aren't traceable to this.
  11. GC-Flitterkill added a bug in IPS4 Bug Tracker   

    [Beta4a] Commerce template errors
    Multiple, depending upon section being hit in the ACP for Commerce. Here's one after attmepting to add product (after adding group):
    exception 'BadMethodCallException' with message 'NO_TEMPLATE_FILE - C:\wamp\www\ips_037cb/themes/1/html/nexus/global/forms/weight.phtml' in C:\wamp\www\ips_037cb\system\Theme\Dev\Template.php:88 Stack trace: #0 C:\wamp\www\ips_037cb\applications\nexus\sources\Form\Weight.php(49): IPS\Theme\Dev\_Template->__call('weight', Array) #1 C:\wamp\www\ips_037cb\applications\nexus\sources\Form\Weight.php(49): IPS\Theme\Advanced\Template->weight('p_weight', 0, 'kg', NULL, false) #2 C:\wamp\www\ips_037cb\system\Helpers\Form\FormAbstract.php(249): IPS\nexus\Form\_Weight->html() #3 C:\wamp\www\ips_037cb\system\Helpers\Form\Form.php(348): IPS\Helpers\Form\_FormAbstract->rowHtml(Object(IPS\Helpers\Form)) #4 C:\wamp\www\ips_037cb\system\Node\Controller.php(394): IPS\Helpers\_Form->__toString() #5 [internal function]: IPS\Node\_Controller->form() #6 C:\wamp\www\ips_037cb\system\Dispatcher\Controller.php(85): call_user_func(Array) #7 C:\wamp\www\ips_037cb\system\Node\Controller.php(63): IPS\Dispatcher\_Controller->execute() #8 C:\wamp\www\ips_037cb\applications\nexus\modules\admin\store\packages.php(40): IPS\Node\_Controller->execute() #9 C:\wamp\www\ips_037cb\system\Dispatcher\Dispatcher.php(124): IPS\nexus\modules\admin\store\_packages->execute() #10 C:\wamp\www\ips_037cb\admin\index.php(13): IPS\_Dispatcher->run() #11 {main} And so on for other areas - essentially the same error just pointing at different templates.
    My ACP currently has the rebuilding stuff locked at 0% in the dashboard and I can't access the community on the front end either (generic 500 error) so I'll probably toss it all and re-install fresh rather than rely on the upgrade.
    Note this is a WAMP install and those slashes are both forward and back so might be a quote parse problem.
    • 0 replies
    • 0 views
  12. GC-Flitterkill added a post in a topic: Pages Pre-release 3   

    ​ Although on the download page for the Pages pre-release the language changes between alpha/pre-release and beta it is the former.
    When Pages is folded into the primary beta package is the point from which IPS will support it officially - at least for upgrading. The thread posted here just yesterday asking for volunteers to test out the Pages upgrading system seems to indicate we are getting there.
    Now if we could just get a Commerce alpha and maybe a peek at the new Chat before the New Year...
  13. GC-Flitterkill added a bug in IPS4 Bug Tracker   

    [Beta 3a] Search hit highlighting does not hit on full phrase if word from phrase appears earlier in text
    If you search for something that is more than one word, "feel that speed" for example, in search results where no instance of the first word appears earlier the search result is highlighted in the three line truncated text correctly. 
    However if a word from the search term appears by itself earlier in the post that the search algorithm returns, than that word alone is highlighted away from the actual search hit. This is either a highlighting error, a search error not correctly weighing the full search term, or both.
    For example. If I have the following posts:
    Post 1) Nothing to see here.
    Post 2) Feel that speed.
    Post 3) Cmon feel the noise. And some more text. And much more text so that many lines further down the post i would get... Feel that speed...
    The search results page would not hit on post 1, working correctly. Would bring up post 2 and highlight the entire line Feel that Speed, correctly. And finally would bring up post 3, a correct search hit, but would display the line Cmon feel the noise and the next two lines of text and only highlight the word feel.
    Secondary to this is not having the highlighting carrying through when you click on a result but that isn't a bug yet as I don't think you've built out that IPB 3 series functionality in the 4 series yet.
    EDIT:
    Appears this isn't quite true. The three line truncate is just displaying the first three lines of text regardless of whether the search result is within those lines and the highlighting of the single word is somewhat incidental if one of the words just happens to appear in one of those lines. It would be much better if we could get search terms floated up in these displayed results and truncate around them.
    • 0 replies
    • 0 views
  14. GC-Flitterkill added a post in a topic: Staff or devs know where this function is hiding?   

    Thanks; it's also in topic, post, etc php sources. And, it is templated - calling back to contentComment. I thought that was the bit but none of my changes did anything. Probably had only forum posts up in my results page and was editing contentItem instead. One of these days I'm going to walk through some of this stuff and create a map laying out template and function calls per page, in order. 
    Feel free to nuke this thread if you like.
    Also, props for fixing a number of long-standing search bugs involving what used to be searchlite (now mark). Everything I'm throwing at it isn't breaking formatting or skipping over results. Looking good!
  15. GC-Flitterkill added a post in a topic: Staff or devs know where this function is hiding?   

    Looking to move some search elements around. Inside core - front - search - resultStream is...
    {$result->searchResultHtml()|raw} That function is buried somewhere outside the templating system I suspect. At least I'm not finding it. Each search result is pushed out and structured by that function. If anyone can save me some manual searching of the non-template IPS files I'd appreciate it.

Status Feed