zeepeg

Members
  • Content count

    62
  • Joined

  • Last visited


About zeepeg

  • Rank
    IPB Member
  • Birthday 05/05/1951

IPS Marketplace

  • Resources Contributor Total file submissions: 1

Profile Information

  • Gender Male

zeepeg's Activity

  1. zeepeg added a record in IP.Board   

    php closing block tag
    Using closing php block tag ?> in the appname_mysql_uninstall.php screws up the redirect to &do=applications_overview&messageinabottleacp=Application+Removed.

    This occurs on the hosted board at http://cloudcommunities.invisionzone.com/ php 5.2.17
    but not on my board in my lab on W7 box PHP Version 5.2.9-2

    do you have an app note describing the proper use of the closing php block tag ?>?

    z
    • 0 replies
    • 0 views
  2. zeepeg added a comment: full edit setting - line breaks in default missing   

    I have two exports to illustrate the bug.

    the default data in the bad export is the data my app needs.
    And I need that data with the line breaks!!!!!!!

    Have you imported the bad default settings xml to see for yourself the bad behavior?

    z
  3. zeepeg added a comment: full edit setting - line breaks in default missing   

    just upload the bad default settings xml
    click on manage settings and you will see
    [attachment=31637:baddefault.png]

    notice how there are no line breaks.
    now just click to edit settings
    and notice Setting Default Value? has line breaks.
    [attachment=31638:edit-bad default.png]

    now click on save changes and all is right with the world!
    [attachment=31639:after-save-changes.png]

    z
  4. zeepeg added a record in IP.Board   

    full edit setting - line breaks in default missing
    line breaks present with this default setting of full editor
    [attachment=31632:settingGroup_my-good-default-settings.xml]

    line breaks missing with this default setting of full editor
    [attachment=31631:settingGroup_my-bad-default-settings.xml]

    Tell me how to work around this bug

    z
    • 0 replies
    • 0 views
  5. zeepeg added a comment: editing the [quote] tag   

    this issue was related to 3.1.4
    I did not check the box so the default version was in effect
    seems there ought to be a better way!

    z
  6. zeepeg added a record in IP.Board   

    editing the [quote] tag
    [quote name='somebody' timestamp='9999977941' post='666']
    blah blah
    [/quote]

    For what it is worth
    NOTE the timestamp and the link on the quote header
    in the year 2286

    the quotation is just for demonstartion of behavior when allowed to edit the
    [CODE]
    [quote name='theblackelk' timestamp='4444577941' post='119890']
    [/CODE]

    z

    ps sorry to theblackelk, I quoted your post to demo this.
    If you have your quote notifications checked you may receive an email
    • 0 replies
    • 0 views
  7. zeepeg added a record in IP.Board   

    forum delete
    FYI

    ACP forums tab
    forum pull down menu

    you have "empty forum" and "delete forum" options.
    The "delete forum" does [u]not[/u] automatically "empty forum" also.
    After "delete forum" the DB has all the topics and posts that were in the deleted forum.

    The only way the admin knows that there is still some clutter left in the DB is by doing a query on it.

    I have yet to discover if this belly button lent has any deleterious affects on other things or not?
    But cleanliness is next to godliness just the same.

    z
    • 0 replies
    • 0 views
  8. zeepeg added a record in IP.Board   

    full editior and xml
    I am still needing something here
    http://community.invisionpower.com/tracker/issue-29444-line-breaks-in-full-editor-settings-default/page__view__findpost__p__113088
    • 0 replies
    • 0 views
  9. zeepeg added a comment: [Beta 3a] Best Answer enabled forums are not converted to Q&A forums   

    In general the Drop down box requires php code of the form

    if ( $save == 1)
    {
    $_POST['SETTING_KEY'] = "";
    $key = 'SETTING_KEY';
    }

    else the current value never shows the default value.

    z
  10. zeepeg added a comment: [Beta 3a] Best Answer enabled forums are not converted to Q&A forums   

    In general the Drop down box requires php code of the form

    if ( $save == 1)
    {
    $_POST['SETTING_KEY'] = "";
    $key = 'SETTING_KEY';
    }

    else the current value never shows the default value.

    z
  11. zeepeg added a record in IP.Board   

    language strings
    add a language string and put this \"<#TITLE#>\" in it
    and the XML looks just fine
    BUUUUT you look in the lang_cache you find that $lang = array( "\\"<#TITLE#>\\"");
    and that of course is totally hosed
    but worse calling
    IPSText::getTextClass('email')->getTemplate( 'name', $this->memberData['language'], 'group', 'wordpack' );
    crashes the page

    z
    • 0 replies
    • 0 views
  12. zeepeg added a comment: line breaks in full editor settings default   

    But this one don't and it screws up filling in of the full edit box
    the first time the XML is loaded


    [code]
    <conf_type>editor</conf_type>
    <conf_key>full_edit</conf_key>
    <conf_default><![CDATA[<#name#>,

    You have just subscribed to the Zmail for "<#board_name#>".]]></conf_default>
    <conf_extra/>
    <conf_evalphp/>
    <conf_protected>0</conf_protected>

    [/code]

    z
  13. zeepeg added a comment: line breaks in full editor settings default   

    [quote]Selecting Full Editor put this text in the Setting Default Value?
    [quote]
    test

    You have just subscribed to the Zmail for.
    [/quote]

    export it and the result is attached at
    settingGroup_my-settings-5.xml

    [/quote]

    [quote]Selecting Full Editor put this text in the Setting Default Value?

    [quote]
    <#name#>,

    You have just subscribed to the Zmail for "<#board_name#>".
    [/quote]

    export it and the result is attached at
    settingGroup_my-settings-3.xml
    [/quote]

    See no CRLF expansion or
    entities code.
    How do I get it to quit doing that?
    That is why the 1st view after load of XML of the full edit box don't have line breaks!
    z
  14. zeepeg added a record in IP.Board   

    line breaks in full editor settings default
    create a new full editor setting in new settings group
    type in crlf delimited (AKA line breaks, AKA type text press enter) text into the default box
    save the setting, the new contents of full editor has line breaks OK.
    Now IN_DEV export the setting (is XML)
    install the setting from XML

    The CRLF's have been stripped (well not really).

    do this
    load the setting from XML
    the contents of the full edit box has the default text but the line breaks are missing
    now if you edit the setting (not update but edit the setting definition)
    without do anything other than edit and save changes then line breaks magically appear.
    Is an initialization problem!

    Please confirm and devise a work around as this will be very confusing for admins
    note if you update the setting then the missing CRLF's become permanent.
    z

    PS:

    Could you please tell me how to insert line breaks as in when you concatenate two language words.
    and use IPSText::getTextClass( 'email' )->buildMessage( array( 'FORUMLIST' => $crlf_delimited_string));
    the $crlf_delimited_string is stripped of CRLF's on output using
    IPSText::getTextClass('email')->sendMail();

    tks
    • 0 replies
    • 0 views
  15. zeepeg added a record in IP.Board   

    onGroupChange
    While implementing an application MemberSync.php
    class applicationMemberSync
    public function onGroupChange

    We note:
    onGroupChange event is not triggered if changed group is a secondary.
    onGroupChange event is not triggered if changed group is a new registration.

    other observations of behavior:
    Event is triggered if changed group is primary.
    Have not tested but am anticipating that IP.Nexus will trigger onGroupChange

    z
    • 0 replies
    • 0 views

About Me

Status Feed