Winbar

+Clients
  • Content count

    20
  • Joined

  • Last visited


Winbar's Activity

  1. Winbar added a comment: Error during upgrade 3.4.7 - 4.0.0   

    Line in question seems to be:
    if ( mb_strpos( $row[ $column ], 'team_icons' ) AND file_exists( \IPS\ROOT_PATH . $row[ $column ] ) )So either the constant, \IPS\ROOT_PATH should have a / on it, or the value in the DB should have a slash before it.
    Which is g_icon column in core_groups,  which was from g_icon column in groups before the migration.
    Is there a way either of those could have been set incorrectly through the interface etc and can be resolved?
    Thanks
  2. Winbar added a comment: Error during upgrade 3.4.7 - 4.0.0   

    Ah good spot. Wonder where that might be set.
  3. Winbar added a bug in Bug Tracker   

    Error during upgrade 3.4.7 - 4.0.0
    Hi,
    I get an error occurring during the upgrade. I can click continue and the rest of the install completes with no further issues.
     
     

    • 4 replies
    • 91 views
  4. Winbar added a comment: Upgrade from 3.4.7 to 4.0.0 - CSS issues   

    As a side point, the database is copied from live to dev periodically. I presume this is where the issue then occurs as something is still pointing to the original forum location when the CSS is created. Maybe this is something I can fix from within the admin panel when the database is copied?
  5. Winbar added a bug in Bug Tracker   

    Upgrade from 3.4.7 to 4.0.0 - CSS issues
    Hi, 
    I couldn't see any other issues similar to this so will post a bug report for it. 
    We have our main site running on forums.mydomain.co.uk and a dev site (where we test themes and plugins and upgrades) on forums.dev.mydomain.net 
    I switch the theme to default and disabled all hooks and then upgraded the dev site which seemed to upgrade fine, when then returning to the dev forum site after the upgrade an error was displayed. I removed the relevant debug handling from init.php so I could see the real error behind it. The site displayed but appears to have no styling. Looking at the source code there appears to be a set of generates css style sheets (I presume) where the links to said files are pointing to the main site instead of the development site. 
    For example:
    <link rel="canonical" href="https://forums.dev.mydomain.net/index.php?/" />
            
        <link rel='stylesheet' href='https://forums.mydomain.co.uk/uploads/css_built_1/341e4a57816af3ba440d891ca87450ff_framework.css.67f499644bd4e8d720ef982dbe1995f9.css?v=2718b03e8d' media='all'>
        <link rel='stylesheet' href='https://forums.mydomain.co.uk/uploads/css_built_1/05e81b71abe4f22d6eb8d1a929494829_responsive.css.77cf3c52d1ec65a4ac0528ed0472c3cf.css?v=2718b03e8d' media='all'>
     
    I apologise if this this is not the best or correct way to test upgrades before applying them to the live site which has then caused this issue.
    Thanks in advance
     
    • 3 replies
    • 95 views
  6. Winbar added a bug in Bug Tracker   

    [Beta 7] SQL error during upgrade 3.4.7 -> 4.0.0 beta 7
    Hi,
    I am currently performing an upgrade from 3.4.7 to 4.0.0 beta 7 and I'm receiving the following SQL error when I try to navigate to /admin/upgrade/
    Fatal error: Uncaught exception 'IPS\Db\Exception' with message 'Unknown column 'lang_order' in 'order clause'' in /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Db/Db.php:368 Stack trace: #0 /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Db/Select.php(312): IPS\_Db->preparedQuery('SELECT * FROM `...', Array) #1 /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Db/Select.php(210): IPS\Db\_Select->runQuery() #2 /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Lang/Lang.php(103): IPS\Db\_Select->setKeyField('lang_id') #3 /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Member/Member.php(1442): IPS\_Lang::languages() #4 /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Output/Output.php(617): IPS\_Member->language() #5 /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Dispatcher/Setup.php(152): IPS\_Output->sendOutput('...', 200, 'text/html', Array, false) #6 /var/www/vhosts/forums.dev.mydomain.net/httpdocs/admin/upgrade/index.php(13): IPS\Dispatcher\_Setup->run() #7 { in /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Db/Db.php on line 368I reported the error during beta 6 which was set to fixed but appears to still be occurring, so I'm re-raising this as per instructions.
    Thanks
     
    • 2 replies
    • 109 views
  7. Winbar added a comment: SQL error during upgrade 3.4.7 -> 4.0.0 beta 6   

    ​Hi, should this no longer be an issue in beta 7? As I still get the same error when attempting to run the upgrade.
    Thanks
  8. Winbar added a bug in Bug Tracker   

    SQL error during upgrade 3.4.7 -> 4.0.0 beta 6
    Hi, 
    I am currently performing an upgrade from 3.4.7 to 4.0.0 beta 6 and I'm receiving the following SQL error when I try to navigate to /admin/upgrade/
    Fatal error: Uncaught exception 'IPS\Db\Exception' with message 'Unknown column 'lang_order' in 'order clause'' in /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Db/Db.php:368 Stack trace: #0 /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Db/Select.php(312):IPS\_Db->preparedQuery('SELECT * FROM `...', Array) #1 /var/www/vhosts/forums.dev.mydomain.net/httpdocs/system/Db/Select.php(210): IPS\Db\_Select->runQuery() #2 /var/www/vhosts/forums.dev.mydoamin.net/httpdocs/system/Lang/Lang.php(103): IPS\Db\_Select->setKeyField('lang_id') #3 /var/www/vhosts/forums.dev.mydoamin.net/httpdocs/system/Member/Member.php(1437): IPS\_Lang::languages() #4 /var/www/vhosts/forums.dev.mydoamin.net/httpdocs/system/Output/Output.php(617): IPS\_Member->language() #5 /var/www/vhosts/forums.dev.mydoamin.net/httpdocs/system/Dispatcher/Setup.php(152): IPS\_Output->sendOutput('...', 200, 'text/html', Array, false) #6 /var/www/vhosts/forums.dev.mydoamin.net/httpdocs/admin/upgrade/index.php(14): IPS\Dispatcher\_Setup->run() #7 { in /var/www/vhosts/forums.dev.mydoamin.net/httpdocs/system/Db/Db.php on line 368 In order to do the upgrade, I have kept the public and uploads folder as well as the conf file, and removed all other files and then uploaded the new beta 6 files. I hope that is correct as I seem to get undesirable results when I did the beta 5 upgrade by just overwriting the files, so presumed it was best to remove them (also following another suggestion on this forum). Apologies if I have done the upgrade wrong in the first place. 
    Hope you can help.
    Thanks
    • 3 replies
    • 177 views
  9. Winbar added a post in a topic: Show next [x] calendar events   

    Hi,

    I've had a good look in the settings and over the IPS marketplace and I can't find anything that provides this functionality.

    The option to show events for the next [x] amount of days exists in the calendar settings but it would be really useful to be able to show the next [x] number of events instead. This helps to keep the side block the same height all the time and allows us to show a consistent amount of events rather than a continual changing amount.

    Thanks :)


Status Feed