erosion

Members
  • Content count

    58
  • Joined

  • Last visited


1 Follower



About erosion

  • Rank
    IPB Member

Profile Information

  • Gender Male

erosion's Activity

  1. erosion added a comment: Upcoming Calendar Events sidebar applies timezone difference two times   

    The bug can be reproduced just as well with a completely unmodified hooks.php :

    By setting my user accounts timezone to something that makes an event take place near midnight (eg. 23:30) for me, the sidebar will show the event taking place on the following day, hence proving that the 'doubling' of the timezone difference takes place regardless of the strftime string.
  2. erosion added a comment: Upcoming Calendar Events sidebar applies timezone difference two times   

    [color=#282828][font=helvetica, arial, sans-serif][size=3]To be more precise, the only modification I have made is to the strftime string on line 358 of hooks.php:[/size][/font][/color]

    [color=#282828][font=helvetica, arial, sans-serif][size=3]FROM[/size][/font][/color]

    $c_time = gmstrftime( '%x', $event['_start_time'] );

    [color=#282828][font=helvetica, arial, sans-serif][size=3]TO[/size][/font][/color]

    $c_time = gmstrftime( '%A %d.%m. %H:%M', $event['_start_time'] );
  3. erosion added a record in IP.Calendar   

    Upcoming Calendar Events sidebar applies timezone difference two times
    I have modified the hooks.php to display the start time of events in the sidebar and it has worked ok for us so far.

    After updating both the forum and the calendar to the most recent versions, the sidebar now displays the times wrong.

    By modifying the users own timezone setting it becomes apparent that the timezone difference is applied two times to the sidebar list of events.

    -all of our users have GMT+2 in their own settings
    -sidebar start times are +2 hrs off
    -changing the users timezone setting to, for example, GMT+3, results in sidebar times being +3 hrs off.
    • 0 replies
    • 0 views
  4. erosion added a comment: Switching to mobile skin on desktop, users unable to get back to full version.   

    Same experience in 3.3, how is this classified "not a bug", beats me. I'm using IPB default skins. If users choose mobile skin, they can't get back to the full version on the mobile device. One user account got stuck in the mobile skin even on desktop computers, this can be manually fixed from ACP->Template Tools->Reset Skin Set Usage.

    I had to disable the mobile skin altogether because there are so many issues, it's basically unusable now.

About Me

Status Feed