Jump to content


Photo

Comment notifications no longer working


Comment notifications are no longer working. It started in 2.3.0 and carried into 2.3.1. My members are fussing about it.

Status: Fixed
Version:
Fixed In: 2.3.2


16 Comments

Have you setup your notification options in the UCP? Everything has been moved there, you need also to "like" an entry in order to receive notifications of the comments.
I see the list of notification options in UCP but not this one. It is for when someone receives a comment on their blog.
We still have the "New Comment Notification" setting in My Settings->Blog->Manage Settings.

That setting no longer has any effect. Because, once it gets into the like system, there's no like entry.

Users have to 'like' each of their blogs to receive comment notification.
Ok.. More details on this.. First.. If you like your blog.. You don't receive comment notifications. You have to like each entry individually.

If you like each entry individually, there's a fair chance you STILL won't receive notifications. Because the language.xml file apparently isn't being applied on upgrades.

I'll attach that file..

And, if you go to ACP->Manage Languages and import that file.. Then the user likes a blog entry.. And sets it to notify them of new comments, AND has Notify me of new comments enabled in My Settings->Notification Options, then they should get a notification.
Updating severity to: 2 - Fair
Updating status to: Confirmed - General
Updating version to: 2.3.0

Ok.. More details on this.. First.. If you like your blog.. You don't receive comment notifications. You have to like each entry individually.

That's WAI.


Will double check the rest.
Updating severity to: 0 - None Assigned
Updating status to: Cannot Reproduce

It works just fine for me locally, both admin/moderator or normal member.

Be sure that you have the notification options for "New comments" enabled and you like the entry you want to receive notifications for.
If anyone is still having troubles even after checking the notification options and liking the entry please submit a ticket so we can investigate on your boards.



Note: The missing language string is a fix in IPB 3.2, can't do much about it.
Updating status to: Confirmed - General

Talked this over with Jason, will look again into it as it's related to a completely different setting rather than notifications.
Updating severity to: 2 - Fair
Updating status to: Fixed
Issue fixed in: 2.3.2

Okay, I have made that if the blog setting "New comment notification?" is enabled the user automatically 'likes' the blog entry and will be notified of new comments BUT you must have the notification options for "New Comments" enabled in your UCP anyway.
Tested.Double checked and made sure I should be notified by all methods for comments.

Posted half a dozen comments as another member, then signed back in, it said I had no notifications at all.

No email notification either (made a note to check that I had checked the old Blog option for it as a re-test) , using fake mail setting but other things such as profile comment emails arrive so that's OK, but nothing at all for Blog, no notification nor email.
Updating status to: Confirmed - General
Updating version to: 2.3.0
Issue fixed in: None

I'll double check tomorrow, but it was working when I tested.. :\
What I found when testing this is that it goes back to the commenting system.

If you add a comment, it only sets the MD5 or whatever code that is for a blog entry. So, the only way you would be notified is if you like the particular entry.

What's also.. Wrong.. Is that if you like a blog itself..

http://community.inv...-jason-hs-blog/

Click the like button there. It says "Notify me of comments".. That has no effect. That's entered into core like as blog/blog, and when you enter a comment, it's looking for blog/entry
I setup the code to like the entry itself after you post it and not the blog, that's why I'm confused. I'm taking another look at it now anyway.
Updating status to: Fixed
Issue fixed in: 2.3.2

I can confirm it works fine for me locally after the fix. Andy/Jason call me on aim and we can take a look to see if there's something missing.
Found why andy was confused: note that the fix applies ONLY to new entries made after the fix, for all old entries made before you'll need to go back and like them manually. Can't do much about that, sorry.
Another issue is that you're missing the "comment_notifications" language string (email template) and the notification is not sent because of it.

If that happens take a look at this other bug report in the IPB project: http://community.inv...post__p__105532
Only for fresh installs :)

Double checked the 231 and 142 upgrades (as requested) and they are both intact regarding that.