Jump to content


Photo

View New COntent Search Results


On my board I had 3 topics displaying in a forum category. The ones that I had read stayed visible until I had read the 3rd and final topic in that particular category, then all 3 vanished.

Same issue that was fixed at http://community.inv...ms-not-to-work/

This seems to have reappeared as a bug on a fresh install of 3.1.2 but does not identify as a problem on upgraded version.

Status: Fixed
Version: 3.1.2
Fixed In: 3.2.0 Beta 1


7 Comments

I'd like to highlight the 'view new content' does not behave as I would expect it to, discussion here.
Summary: after I have read every single post or reply on my forums, I would expect that search to return zero results, when in fact it mostly returns things I've read before.

I'd like to highlight the 'view new content' does not behave as I would expect it to, discussion here.
Summary: after I have read every single post or reply on my forums, I would expect that search to return zero results, when in fact it mostly returns things I've read before.


Note that this is directly affected by the "View New Content Method" setting in the UserCP. Sounds like you've got it set to "Show me content since my last visit".
Updating status to: Confirmed - General

I've not tested the bug report. I'm relatively certain, as well, that Matt indicated he would need people to submit tickets if they were having issues with search/VNC at this point, but will confirm this for now until Matt returns so I can discuss with him.
Confirmed here as well, and we need to be able to have this working if we do have the option set to 'Show me content since my last visit' and then read all new posts. It has to be consistent.

Confirmed here as well, and we need to be able to have this working if we do have the option set to 'Show me content since my last visit' and then read all new posts. It has to be consistent.


Actually, no. Those two options should NOT be consistent, otherwise what would be the point of giving the user the option?

"show me all content since my last visit" is designed to show anything that was posted since you last visited
"show me all content I have not read" is designed to show anything that was posted that you haven't viewed, whether it was since your last visit or not


Those two options should not be consistent. That would be a bug in and of itself.
Sorry that was a typo, I meant to state 'show me all content I have not read, serves me right for posting quickly from work :)
Updating severity to: 2 - Fair
Updating status to: Fixed
Issue fixed in: 3.2.0 Beta 1