Jump to content


Photo

Error: Could not load template 'feed__generic_x' from group ''


When a feed block is created with caching enabled and using the generic list template this error is thrown.

Error: Could not load template 'feed__generic_x' from group ''

The critical step appears to be enabling caching during creation. If you subsequently disable caching and re-enable it the error is no longer thrown.

I created my block as a latest replies feed block with all default settings though I don't think this is important to be able to reproduce.

Status: Unconfirmed
Version: 0
Fixed In: 2.3.2


13 Comments

Give them access to your ACP :)
Just bumping this for a question ; would it be possible to have a quickfix for this bug ?
On ym install, it's absolutely impossible to have caching working (on blocks ; on pages, it does work)...

thanks
Any fix for this one would be nice!
There are multiple files in multiple places that need to be edited. I'm afraid there isn't a quick fix for this, beyond not caching the block. If you don't cache the block, the block template will work correctly.
I'm sorry to bump this again.
Makes me wonder if anyone is actually using IPC on a high traffic website. My homepage is ready, it has 80 queries ( it is complex ).

An average IPC homepage with half a dozen of block probably is in the vincinity of 50 queries.

I, and probably others, cannot put anything online with no caching at all with such a query count. That's why block caching is in place. Page caching does not help ; blocks have to be cached separately, some things move faster than others in my HP.

This bug, which exists since 2.3.0 and which i've described since day one, ranked severity 3 here, prevents IPC2.3 users to actually use the product on a semi-popular live install.

please understand my "simple customer" frustration.
No quickfix, no patch, and here we are friday again with no 2.3.2 release for a showstopping bug which exist since a month...
This is not exactly a "showstopping" bug. You have a simple workaround by toggling ACP options. I understand there are reasons you don't want to use the options which work around this issue, but it is entirely possible to do so.

It would be a temporary solution until 2.3.2 is released, which will not be long. I'm afraid it is simply unrealistic to release a patch for each and every issue that someone faces - we would spend more time writing patches than actually fixing the code and releasing said patches to the world.

We are actively working on 2.3.2 and I hope to have it out before long.
Have same problem and use 2.3.2 ver of IP Content ... how to fix that?
Photo
Marcher Technologies
Sep 06 2012 05:40 PM
I am able to successfully reproduce this in one reliable way on 2.3.2.
Edit a Block Using a Template Gallery Block Template.
Touch nothing, click Step 6 on the steps bar.
Then Click step 5(note, it is showing 'Custom Template' inaccurately).
If you do not save or save+reload here on step 5, (usually accompanied with reselecting the block template from the template gallery), that error will occur.
'Next' from step 5 does not do this, if that helps/matters.
Caching, also appears to not be related to this one.... currently not caching the blocks I am reproducing this with while testing.

I was also able to reproduce this in 2.3.6

 

Comment #2 has a temporary workaround: http://community.inv...om-group-r41395

Updating Status to: Unconfirmed
Updating Version to: 0

I am able to successfully reproduce this in one reliable way on 2.3.2.
Edit a Block Using a Template Gallery Block Template.
Touch nothing, click Step 6 on the steps bar.
Then Click step 5(note, it is showing 'Custom Template' inaccurately).
If you do not save or save+reload here on step 5, (usually accompanied with reselecting the block template from the template gallery), that error will occur.
'Next' from step 5 does not do this, if that helps/matters.
Caching, also appears to not be related to this one.... currently not caching the blocks I am reproducing this with while testing.

 

I will retest with these (very specific...) steps.

Well, it's December, and I also have this issue.  I'm just trying to add a block to my sidebar:

 

 

And it produces the error stated by everyone here.

 

I'm using 3.4.6.

You can already fix the problem by editing the block and selecting the template - this issue is more a nuisance when running through a very specific set of steps.  If you aren't following the steps above, submit a ticket.  If you ARE following the steps above....don't do so and you won't have a problem.

    • Marcher Technologies likes this