Jump to content


Photo

Page Template not working the same after upgrade to 2.3.1


I have a page template which contains the following:

<php>$this->registry->output->addToDocumentHead('raw', '<link rel="stylesheet" type="text/css" media="screen" href="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.14/themes/smoothness/jquery-ui.css">');</php>
{parse addtohead="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.14/jquery-ui.min.js" type="javascript"}
{parse addtohead="elfinder/js/elfinder.min.js" type="javascript"}
{parse addtohead="elfinder/css/elfinder.min.css" type="importcss"}
{parse addtohead="elfinder/css/theme.css" type="importcss"}
{ccs special_tag="page_content"}

Right up to version 2.3.0 this worked fine, but now it doesn't, none of that is getting included in the page that uses it.

Status: Fixed
Version: 2.3.1
Fixed In: 2.3.2


8 Comments

That code is being injected just fine for me. Remember you can't use it in a page, only in templates or blocks. Otherwise, I just verified my HTML source has that code added in and the page displays correctly.
I'm using it in a page template, that should work right?
Yes...and it does for me (I tested with your exact code). Do you use the IPB wrapper?
Yes and its setup to only edit page content.
I recommend submitting a ticket then. Worked fine when I tested it.

Posted Image

(more below, but it's not worth ss'ing it all)
Cache the page, and it doesn't include it.
This doesn't appear to be related to IP.Content changes, but rather changes in IP.Board 3.3.x. In any event, found a work around.
Photo
PrinceOfAbyss
Apr 25 2012 01:18 PM
Maybe this is related to my report in a way?