Jump to content


Photo

slug memory... default page... omit filename... oddities.


ok... this took a support topic to uncover, but it goes along these lines.
Site is set up, happily running, site upgrades, site decides they do not want index.html in their default page, and tick the option with the appropriate default page setting.
No redirects occur for any records within the database parsed on the page, no slug memory is made.

Status: Fixed
Version: 2.3.1
Fixed In: 2.3.2


6 Comments

Photo
Marcher Technologies
Apr 05 2012 03:10 AM
did i mention i can duplicate this behavior on articles.html on stock fresh 2.3.1? seems not.... apologies... had to go test this one myself.
I made "articles.html" my default page, then edited the articles.html page to omit the page name in the URL.

When I visited an article it loaded without /articles.html/ in the URL as expected. If I manually add it, it redirects me back to the home page of the database (because it is redirecting the page, but not appending the database string to the URL). I fixed that so that it would retain the database URL data, but I can't seem to reproduce the original issue you mentioned.

For the record, no slug memory is needed for what you are describing.
bfarber, is their anyway u can tell me the fix? My all links are broken at present...

http://mygamingtalk....release-051-r78

doesn't redirect to

http://mygamingtalk....release-051-r78
Photo
Marcher Technologies
Apr 05 2012 11:04 AM

I made "articles.html" my default page, then edited the articles.html page to omit the page name in the URL.When I visited an article it loaded without /articles.html/ in the URL as expected. If I manually add it, it redirects me back to the home page of the database (because it is redirecting the page, but not appending the database string to the URL). I fixed that so that it would retain the database URL data, but I can't seem to reproduce the original issue you mentioned.For the record, no slug memory is needed for what you are describing.

okies. the issue being reported is that the database url data is not retained, ergo, a database record on a page changed such will be found to 301 to the page, instead of 301 to the proper database record url.

okies. the issue being reported is that the database url data is not retained, ergo, a database record on a page changed such will be found to 301 to the page, instead of 301 to the proper database record url.


Ok, THAT I duplicated and fixed (as I noted above). I misunderstood what you were reporting apparently, but ended up noticing the same thing.

bfarber, is their anyway u can tell me the fix? My all links are broken at present...http://mygamingtalk....release-051-r78doesn't redirect tohttp://mygamingtalk....release-051-r78


As noted here, it is redirecting in my tests, however it loses the database information so it redirects to the homepage. That will be fixed in the next release.