Jump to content


Photo

mobile index needs help


Has anyone actually browsed the MP on the mobile theme?

Attached Image: Screenshot from 2012-07-25 18:59:09.png

Attached Files


Attached Image: Screenshot from 2012-07-25 18:59:09.png

Status: Not a Bug
Version: 0
Fixed In: 0


6 Comments

Photo
Marcher Technologies
Jul 25 2012 08:01 PM
ugh... can someone tidy that? serves me right for posting on normal skin with my account still on mobile from taking the screenshot.... text mangle FTW.
Sorted that for you.
    • Marcher Technologies likes this
Updating Status to: Not a Bug

IP.Downloads does not support the mobile skin at this time. This is why there is no link there (at least last I checked).
Photo
Marcher Technologies
Jul 26 2012 08:26 AM

Updating Status to: Not a Bug

IP.Downloads does not support the mobile skin at this time. This is why there is no link there (at least last I checked).


The skin changer on the page is a direct link.
the fact html templates are produced looking like that instead of a proper listing or an empty wrapper is.... ok?
My site does this as well, as does every IPD install.... to me it is not, but I won't argue it further if insistent.
It does it on every single IP.Downloads installation because IP.Downloads does not support the mobile skin at this time.

When we build mobile templates for IP.Downloads to support the mobile skin, it will look proper at that point. Until such time, the mobile skin does not intentionally link to IP.Downloads.
Photo
Marcher Technologies
Jul 26 2012 05:49 PM

It does it on every single IP.Downloads installation because IP.Downloads does not support the mobile skin at this time.

When we build mobile templates for IP.Downloads to support the mobile skin, it will look proper at that point. Until such time, the mobile skin does not intentionally link to IP.Downloads.


Ok... then is it a bug these templates have html in them for the mobile skin? is IPB doing this? If an app(any) does not support the mobile skin, will IPB decide to use the normal skin html templates in the mobile skin(ergo, inserting them into mobile, not empty, but with the wrong html) instead of the blank wrapper that sanely shows not supported?
Also... you really should realize that not intentionally linking to it by no means stops any user from getting there and account accordingly(logic check... we never directly link the ajax modules, so it's 'ok' if it doesn't return nopermission by default? no difference here).... I raised it as a bug not because it is not supported, but because it returns HTML like it is supported when it is clearly not.