Jump to content


Photo

mobile images dont resize to fit width


Image view.
Posted Image

Status: Fixed
Version: 5.0.0 Beta 1
Fixed In: 5.0.0 Beta 1


13 Comments

Updating Fixed In to: 5.0.0 Beta 1
Updating Status to: Fixed

-
It's working just fine for me. Maybe try clearing your cache - the fix was in the CSS mostly.
I did that..even tried installing a new browser. What phone and browser is it working on? I have android and tried boat browser, opera, and chrome. When I view the source I don't see this anywhere.

#content .galmedium {
max-width: 100%;
}
I used my iPhone (with mobile safari) to visit the image you linked to on our company forums.
<p>Doesn&#39;t work here.</p>
<p>&nbsp;</p>
<p>http://www.testiphone.com/</p>
That link is loading the full skin when I try to test it.

I don't know what to tell you right now - you pointed out the CSS change that fixes this, so you must see that the CSS change has been included in the release. It's working fine for me on this site and locally.
Well of course but if you switch to the mobile skin on that site and then go into the gallery you'll see that the css is not taking effect.

Anyway...I have no idea why it's working properly for you, but the CSS is wrong. It should be .galattach not .galmedium. :P

Maybe iphone is being smart and autoresizing.
Uh...no? It has

class="galmedium"

It doesn't have galattach class at all on the image view page. You are starting to confuse me...
<p>Ok so 1) it seems the company forums don&#39;t have the proper css. Can&#39;t find galmedium in the source.</p>
<p>&nbsp;</p>
<p>2) My setup has galattach instead of galmedium because in the resize settings I have medium sizes blank and I rebuilt all images. I just changed the settings to restore the medium size defaults, rebuilt all images, and the class switched to galmedium.</p> So just add galattach to the css.
http://community.inv...m-28451-sample/

http://screencast.com/t/oJsHrHhjO

Now, your last statement regarding not having medium sized images is valid, so I'm going to change it....but I have no idea what you are talking about saying the company forums doesn't have galmedium in the source. That screenshot is of the source code on the page you linked to. It does have galmedium in the source (but not galattach on the main image view).

Anyways, I edited the mobile skin to add id 'mobileImageWrap' to the container div, and changed the CSS to

#mobileImageWrap .galmedium, #mobileImageWrap .galattach {

It (still) works for me - hopefully it resolves the issue for you.
I'm talking about the CSS in the minified stylesheet not the class. :P
http://content.commu...2/ipgallery.css

That stuff. Switch the mobile skin and check it. .galmedium isn't in there...
Don't know why that link doesn't work...but yeah. I am looking for where the css rules for .galmedium are defined in the mobile skin. Hope that makes sense. :unsure: