Ordering Page Is Insecure!

9 posts in this topic

Posted

I am using the latest Google Chrome and was going to purchase IP.Board today however the ordering process is insecure. You have SSL however this is the following message Google Chrome is giving me:



The HTTPS in the address bar of chrome is red with a red line through it. This is at Step #1 of #3 of the order process. I don't trust it. Please look into it and get back to me. =)

Your connection to www.invisionpower.com is encrypted with 256-bit encryption. However this page includes other resources which are not secure. These resources can be viewed by others while in transit, and can be modified by an attacker to change the behavior of the page.

Share this post


Link to post
Share on other sites

Posted

So they forgot to deliver some images over HTTPS?

I think thats just stupid HTTPS. Though, thats my opinion.

Share this post


Link to post
Share on other sites

Posted

The page itself is secure, however IPS loads things on that page that are considered insecure elements. None of them relate to the order form, and I have never had a problem. If you click the little "Lock" button next to the red HTTPS: it explains it.

Share this post


Link to post
Share on other sites

Posted



You guys are probably right but I don't take chances. I don't exactly have the best of luck to begin with. Lol. :no:

The site uses SSL, but Google Chrome has detected either high-risk insecure content on the page or problems with the site’s certificate. Don’t enter sensitive information on this page. Invalid certificate or other serious https issues could indicate that someone is attempting to tamper with your connection to the site.

Share this post


Link to post
Share on other sites

Posted

You are worried about the logo that they load from a "normal" adres?

Share this post


Link to post
Share on other sites

Posted

[quote name='Invision Nederland' timestamp='1326355377' post='2219818']
You are worried about the logo that they load from a "normal" adres?


I don't know whats causing it. I'm not sure how SSL really works to be honest. I've always been told/taught that as general rule you never input personal information for billing and whatnot unless the connection is secure. Green means good. Red means bad. Nothing means worse. That's about my current level of understanding when it comes to SSL. :sweat:

I'm just now really starting to learn web programming with the assistance of books. I'm sure I'll learn all about SSL in due time. :grin:

Share this post


Link to post
Share on other sites

Posted

We are looking into this issue, it is secure, however it's pulling some images from our servers without https, there is no security issue at all, however it will throw an error due to the images as mentioned.

This should be resolved shortly :)

Share this post


Link to post
Share on other sites

Posted

[quote name='Rhett' timestamp='1326359909' post='2219832']
We are looking into this issue, it is secure, however it's pulling some images from our servers without https, there is no security issue at all, however it will throw an error due to the images as mentioned.

This should be resolved shortly :smile:


Cool. Glad to know its nothing serious. :hyper:

Share this post


Link to post
Share on other sites

Posted

It should be okay now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Who's Browsing   0 members

    No registered users viewing this page.