Sign in to follow this  
Followers 0

SEO issues - Duplicate content

15 posts in this topic

Posted

Similar to the issues with IP.Board as discussed here: http://community.invisionpower.com/topic/363264-seo-rankings-flying-all-over-the-place-and-why-is-this/

IP.Blog suffers similar issues. Although perhaps worse. Example:


http://community.invisionpower.com/blog/1174/entry-7484-additional-ips-community-enhancements/

http://community.invisionpower.com/blog/1174/entry-7484-additional-ips-community-enhancements/page__st__20

http://community.invisionpower.com/blog/1174/entry-7484-additional-ips-community-enhancements/page__st__20#commentsStart

Though #commentsStart isn't technically a new page.

Anyway pages 2+ not only display the exact same <h1> <title> but also the same content, minus the comments which change.

The fix for this, wouldn't be the same as the fix for the duplicate content issue in the forums. Because page 2, should not even exist.

The proper fix would be to load the additional comments via ajax. Then 301 redirect page__st__xx to the main blog post.

These duplicate content issues are really bad guys, this kind of thing, is exactly what Panda was designed to penalise against.

I really feel strongly, that all development should be put on hold and these SEO issues resolved. They're not mere optimisations, they're fixes for duplicate content. No new feature, or bug fix can be as important as these issues, which can cause a massive drop in traffic, if flagged by Panda.

Google webmaster tools, has tens of thousands of duplicate title and meta desc flags, coming from various areas of the IP. applications.

I have had to do a quick fix on the blogs and forums and noindex page 2+. It's not a fix as such, but it's at least going to prevent the duplicate content issues.

Cheers.

civ, CallieJo, Maxxius and 1 other like this

Share this post


Link to post
Share on other sites

Posted

Issue #2

All category pages have identical titles to the main blog.

Fix
Add the category to the title. I would go as far as removing the blog name, from these pages.
Add an opinion in IP.SEO to noindex these pages

civ and Maxxius like this

Share this post


Link to post
Share on other sites

Posted

I'm gonna stop posting problems and fixes, the issues are just too extensive. It's taking long enough to find them and then further time to report here and I have no idea whether my posts are being appreciated by the devs or whether they're being seen as a nuisance. These are major issues, I'm having to hire a developer to manually fix the issues, until they're officially resolved.

Average joe wouldn't even have a clue these problems exist, so it's left to the few who do know to debate and it's taking up a lot of my time. Especially as this is a public forum and everybody, expert or not, chimes in and just complicates matters.

It would be worth checking out: http://www.seomoz.or...ost-panda-world

This outlines possible problems with duplicate content post Panda. All of the issues I've been outlining are mentioned here as problems.

Matt, if you would like my help in properly diagnosing all of the issues in the IP applications, feel free to drop me a PM.

SEO issues right now should be a priority or least have a dedicated team taking care of them.

Cheers,

Paul

Maxxius, civ, blair and 3 others like this

Share this post


Link to post
Share on other sites

Posted

I have more then tons of issue regarding blogs and SEO. Wrong links, wrong URL's, duplicate titles, etc. It's mess of SEO. Traffic dropped by 20% due to duplicate contents. But hey content is king :)

realmaverickuk and blair like this

Share this post


Link to post
Share on other sites

Posted

Yeah. Content is king, until your internal architecture is screwed, then Panda is king!

civ likes this

Share this post


Link to post
Share on other sites

Posted

Try this: _http://fearless-assassins.com/blog/22/entry-159-gaming-simplified/

No idea from where Google found this.. but it did. Correct link: http://fearless-assa...ing-simplified/

Above link causes 301 errors continuously....and their are "tons" of 301 error like it...

http://awesomescreenshot.com/0c87mbp41

realmaverickuk likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='AlexJ' timestamp='1339225822' post='2275772']
Try this: _http://fearless-assassins.com/blog/22/entry-159-gaming-simplified/

No idea from where Google found this.. but it did. Correct link: http://fearless-assa...ing-simplified/

Above link causes 301 errors continuously....and their are "tons" of 301 error like it...

http://awesomescreenshot.com/0c87mbp41


You should submit a ticket and/or a bug report if you find a bug.

Share this post


Link to post
Share on other sites

Posted

[quote name='bfarber' timestamp='1339414920' post='2276401']
You should submit a ticket and/or a bug report if you find a bug.


I submitted the ticket and got answered it's working as intended. I am not going to quote here what IPS tech staff said.... All I want is to get this bug/issue fixed in next release or if possible please provide separate patch for it for this release.

I am fairly certain that support tech didn't even bother to look at issue in detail and didn't analyze excel sheet i provided. How can be this valid URL? But according to IPS support tech it is and their is nothing wrong in it.



Please let me know what I should do now. Massive 301 errors from blog are increasing.

http://fearless-assassins.com/forum/blog/122/entry-181-good-people-not-just-good-players/user/3089-dougls/

Share this post


Link to post
Share on other sites

Posted

As a fellow user, I just want to say thanks to those of you who are reporting this stuff. It's a big deal to all of us, and it is definitely appreciated!

Share this post


Link to post
Share on other sites

Posted

[quote name='AlexJ' timestamp='1339759597' post='2277765']
I submitted the ticket and got answered it's working as intended. I am not going to quote here what IPS tech staff said.... All I want is to get this bug/issue fixed in next release or if possible please provide separate patch for it for this release.

I am fairly certain that support tech didn't even bother to look at issue in detail and didn't analyze excel sheet i provided. How can be this valid URL? But according to IPS support tech it is and their is nothing wrong in it.



Please let me know what I should do now. Massive 301 errors from blog are increasing.


What's the ticket ID? I'd just like to review as it seems like something is missing or not communicated clearly here.

http://fearless-assassins.com/forum/blog/122/entry-181-good-people-not-just-good-players/user/3089-dougls/

Share this post


Link to post
Share on other sites

Posted

[quote name='bfarber' timestamp='1339770998' post='2277818']
What's the ticket ID? I'd just like to review as it seems like something is missing or not communicated clearly here.


Thanks Brandon! Ticket also contains excel sheet from Google Webmaster tool where it showed all 301 errors. If you need anything else please let me know!

Here is the ticket ID: 804792

Share this post


Link to post
Share on other sites

Posted (edited)

Ah, ok reviewing the ticket the on specific URL you pointed out wasn't discussed (just 301 redirection in general). The URL you provided above I believe would be a bug and will file a bug report for you.

http://community.invisionpower.com/tracker/issue-37867-relative-user-profile-url/

Edited by bfarber
Added link

Share this post


Link to post
Share on other sites

Posted

I have 500 errors also, like this:



when I click the link, inside "Google webmaster tools" my forum says:

Oops! Something went wrong!

We use an authorization key to verify you really submitted the form, and the authorization key was not supplied with your form submission or was invalid. Please go back, reload the form and try to submit it again. [#5031]


http://mysite.com/forum/index.php?app=forums&module=moderate&section=moderate&f=238&st=0&auth_key=bb2fe024f8a71424996db6d9af08c1fc&do=sdelete&t=

Share this post


Link to post
Share on other sites

Posted

[quote name='Gianpiero L.' timestamp='1339928392' post='2278361']
I have 500 errors also, like this:

http://mysite.com/forum/index.php?app=forums&module=moderate&section=moderate&f=238&st=0&auth_key=bb2fe024f8a71424996db6d9af08c1fc&do=sdelete&t=

when I click the link, inside "Google webmaster tools" my forum says:

Oops! Something went wrong!

We use an authorization key to verify you really submitted the form, and the authorization key was not supplied with your form submission or was invalid. Please go back, reload the form and try to submit it again. [#5031]


This is unrelated to the discussion

1) That's a forum URL, and has nothing to do with Blog (Blog does not generate or control that URL)
2) That issue I believe was fixed in a previous release already. You may have an outdated skin that has not inherited the fixes.




			
		

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Who's Browsing   0 members

    No registered users viewing this page.