Jump to content


Photo

Database to Forum Post - Multiple Content flags?


  • Please log in to reply
3 replies to this topic

#1 Mack_au

Mack_au

    IPB Full Member

  • Members
  • PipPipPip
  • 175 posts

Posted 10 June 2012 - 12:34 PM

I've been setting up a database system for my site, and am intending to then go and have that record create a thread in our forum (which I may then promote to an article for the front page, very tricky I know, but it's working out so far).. I've run into a problem.

I can only flag one record as 'content'.

That's a problem.

My database is setup to have everything I could need to post in a thread, but there's no actual option to get all of those things into the post except one.

This means I'll have to manually edit the post to add the records. The entire point of automating the system by spending an entire day and night on setting up the database system was to avoid having to manually do anything except add the record, and then go make it an article.

For a better example:

If I have the "Title" be the Content, then the post comes up something like this:

Title of Test

Click here to view the record


What I'd like for it to do is:

Title of Test
Date: 20 June 2012 - 03:31 AM
Opponent: Test Opponent
Competition: Test Competition
Location: Test Location
Stadium: Test Stadium
Result: To Be Determined

Click here to view the record


Have I explained that right? Have I missed an option somewhere?

If it can't be done now could it be included as an option in the future? Considering how this software is all about integration, it'd be good to have a Template that you could setup to transfer the DB record over to the forum post in whatever style the template sets out.

x1hjea.png


#2 Mack_au

Mack_au

    IPB Full Member

  • Members
  • PipPipPip
  • 175 posts

Posted 11 June 2012 - 01:32 AM

Okay, I've figured out I had missed the Topic format area, but I've still got a couple issues.

When I try to show the date in the forum post, it comes up with just numbers. Is there any way to show the actual date?

Date: 1339453980

Secondly, how can I get the Topic Format to display an image? I want to setup a dropdown option for links to various pictures which will then become part of the forum post. I don't want to have to edit the forum topic manually. I tried setting it up as a dropdown then having:

[img]{value}[/img]
in the Topic Format area but it simply doesn't translate over to the forum post. Should I be using HTML here? The option for HTML is blanked out so I don't know if that's working.

I've also tried
<img src="{value}" />
but that shows the 3 letter key and not the value itself. This is happening to other drop-down box entries as well, so it's not showing up correctly in the forum post.

x1hjea.png


#3 bfarber

bfarber

    RBT-KS

  • IPS Management
  • 28,640 posts

Posted 11 June 2012 - 06:59 AM

I'd recommend submitting a ticket if you require assistance.

Brandon Farber
Development Manager / Senior Support

If it sounds like fun, it's not allowed on the bus!

php5_zce_logo_new.gif     

Invision Power Services, Inc.


#4 Mack_au

Mack_au

    IPB Full Member

  • Members
  • PipPipPip
  • 175 posts

Posted 11 June 2012 - 07:05 AM

Okay.

x1hjea.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users