mybb 1.6 to ipb 3.3.4 all internal links no longer work

7 posts in this topic

Posted

After upgrade and almost successful conversion (some issues with avatar conversion causing issues with profile pics) it became clear that the post conversion did not change internal links on the site.

This is unfortunate. The mybb /thread-###.html hasn't been converted to the appropriate new URL.
For example the mybb /thread-440.html now results in a 404 because the IPB URL for the same post is /topic/405-subject-line-of-the-thread/

Is there any way to automagically fix this if I still have both databases? There ought to be a way to cross-reference this somehow?

Share this post


Link to post
Share on other sites

Posted

You need to use the URL redirection files, have a look in the Tools directory in the converters zip.

Share this post


Link to post
Share on other sites

Posted

[quote name='stoo2000' timestamp='1348481618' post='2312175']
You need to use the URL redirection files, have a look in the Tools directory in the converters zip.


I'm also with a similar issues - and I can't the that in my converters.zip packages.. Does the mention files have the url sting in the filename ?

Share this post


Link to post
Share on other sites

Posted

[quote name='stoo2000' timestamp='1348481618' post='2312175']
You need to use the URL redirection files, have a look in the Tools directory in the converters zip.

I did that, the config.php for the link redirector is pretty straight forward and difficult to screw up. Yet even though I made the changes in the config and uploaded all the files to the forum root it doesn't do anything.

Share this post


Link to post
Share on other sites

Posted

[quote name='Reality Extractor' timestamp='1348498250' post='2312250']
I did that, the config.php for the link redirector is pretty straight forward and difficult to screw up. Yet even though I made the changes in the config and uploaded all the files to the forum root it doesn't do anything.


Feel free to submit a support ticket and we'll take a look at it for you. :thumbsup:

Share this post


Link to post
Share on other sites

Posted

[quote name='Mikey B' timestamp='1348529589' post='2312498']
Feel free to submit a support ticket and we'll take a look at it for you. :thumbsup:

Actually, there is also bug in the Converters-29_May_2012.zip for the mybb link tool. The content of the config.php is:



The php closing tag is missing. But even with the tag there it doesn't work right. Submitting a ticket now.


<?php


// THE URL TO YOUR IPB FORUMS (no trailing slash or index.php)

define('IPB_URL', 'http://www.yourdomain.tld/ipb3');


// THE PATH TO YOUR IPB FORUMS (no trailing slash)

define('IPB_PATH', '/Users/XXX/Sites/ipb3');


// THE CONVERSION ID

// This would have been asked for when setting up the converters

define('CONV_ID', 'mybb');

Share this post


Link to post
Share on other sites

Posted

The closing php tag is not needed and can be omitted actually. You'll notice a lot of PHP files in IPB missing it.

Reality Extractor and Mikey B like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Who's Browsing   0 members

    No registered users viewing this page.