If you upgrade your forums to 3.0.5

32 posts in this topic

Posted

It will install the "old" chat services back and ruin your IP Chat installation!

Share this post


Link to post
Share on other sites

Posted

yep, just updated to 3.0.5 and screwed my IP.Chat... will have to remove old chat and reinstall IP.Chat.

Share this post


Link to post
Share on other sites

Posted

Good luck with that... I just get a "driver error" when trying. :(

Oh the rush to upgrade bites my arse again!

Share this post


Link to post
Share on other sites

Posted

To fix that DRIVER ERROR, run this query on your SQL Toolbox or PHPMyAdmin:

ALTER TABLE members ADD chat_banned BIT NOT NULL DEFAULT 0;


Now you can uninstall the old chat and install IP.Chat.

It's working for me.

Kamil_K likes this

Share this post


Link to post
Share on other sites

Posted

Aye, thanks, I got rid of it by using these instruction from another thread...

So, you added the column that was missing, then tried to remove the chat application, and it removed the column but then told you the column was missing? If that's the case, try this.



1) Don't re-add the column (make sure it's gone)


2) Via FTP delete admin\applications_addon\ips\chat\setup\versions\install\sql\chat_mysql_tables.php and admin\applications_addon\ips\chat\setup\versions\install\sql\chat_mysql_uninstall.php


3) Try to remove the application again

Share this post


Link to post
Share on other sites

Posted

hrm where is the announcement that IP.Board 3.0.5 is released o0

Edit: nm got it from download section :P Thanks for the heads up for IP.Chat. :)

Share this post


Link to post
Share on other sites

Posted

They didn't post it yet. But it's available on Client Area...

Share this post


Link to post
Share on other sites

Posted


Aye, thanks, I got rid of it by using these instruction from another thread...




Now thre "Chat Services" Application is removed but you cant install IP.Chat (not available on the Application page)............... <_<

Share this post


Link to post
Share on other sites

Posted

Yes, click to instal it and on the next screen it will show IP Chat 1.0 beta 4. (Download that latest beta and upload to your forum).

Share this post


Link to post
Share on other sites

Posted

Ah okay, works fine.

Very confusing. IPS should separate "Chat Services" and "IP.Chat"... Otherwise we will have problems again and again with that (when upgrading IP.Board).

Now i have "Chat Services" and it means "IP.Chat"... lol :blink:

Share this post


Link to post
Share on other sites

Posted

as I said this time I'm gonna resist the temptation of upgrading.... :P

Share this post


Link to post
Share on other sites

Posted

You could also just delete the chat application's folders from the downloaded pack before uploading everything, so IP.Chat files wont be over-written

Share this post


Link to post
Share on other sites

Posted

Downloads, Gallery or Blog works OK after upgrade ?
I will wait until I will have the confirmation that they are working OK with 3.0.5 .

Share this post


Link to post
Share on other sites

Posted

Never mind.

Share this post


Link to post
Share on other sites

Posted

We will do something about chat before it goes final, don't worry. We may just push IP.Chat into the main IPB package, as there won't be much of a need to release it separately really. We haven't totally decided yet.

Share this post


Link to post
Share on other sites

Posted

Thanks for the heads up. I removed all the old chat files in the update and IP Chat is still intact. :D

Share this post


Link to post
Share on other sites

Posted

As Brandon says, use the IP.Chat forum for IP.Chat issues. It is not a bug in IP.Board, because no functionality in IP.Board is affected.


Thats what Mark wrote on the Tracker Entry: http://community.inv...-chat-services/

But i must say: That is not true!!!

"because no functionality in IP.Board is affected"? :unsure:

When we update our Board IP.Chat is crashed / dont work, because (all) IP.Chat files overwritten by the "Chat Services" files.

Thats a huge mistake / bug, whether IP.Chat is beta or not. You must seperate IP.Chat and the "Chat Services" Files, otherwise we become this problem on every IP.Board update.

Share this post


Link to post
Share on other sites

Posted

I ran into a huge problem. After the upgrade, my IPS drivers crashed and prevent me from uninstalling the Chat Services so I can reinstall it.

Share this post


Link to post
Share on other sites

Posted


Thats what Mark wrote on the Tracker Entry: [url="http://community.invisionpower.com/tracker/issue-19993-ipchat-and-chat-services/"]http://community.inv...-chat-services/[/url]



But i must say: That is not true!!!



"because no functionality in IP.Board is affected"? :unsure:



When we update our Board IP.Chat is crashed / dont work, because (all) IP.Chat files overwritten by the "Chat Services" files.



Thats a huge mistake / bug, whether IP.Chat is beta or not. You must seperate IP.Chat and the "Chat Services" Files, otherwise we become this problem on every IP.Board update.




Yeah, so no IP.Board functionality is affected.
IP.Chat is not working - but IP.Chat is not IP.Board - and it's a beta, you willing accepted stuff like this might happen when you installed it ;)

Nobody is saying it's not going to be fixed - I believe the plan is to remove the chat services files at some point - but for now, IP.Chat is not a supported product, the other stuff (Parachat and Sigmachat integration) is, so we can't break that ;)

Share this post


Link to post
Share on other sites

Posted

There is a way to re-install without uninstalling, well a simple upgrading trick.


I ran into a huge problem. After the upgrade, my IPS drivers crashed and prevent me from uninstalling the Chat Services so I can reinstall it.


Share this post


Link to post
Share on other sites

Posted

Mark, what everyone is saying is that the upgrade to IP.Board should not affect those add-ons that have already been previously installed. So, in effect, this was a huge bug that wasn't ironed out. If an upgrade is released, it shouldn't reinstall default services that have been previously removed by the end user. While it's true that we did agree to certain things when Beta testing, this error upgrade bug for IPB should not affect the add-ons, yet it does. This is something that should have been resolved before releasing it.

I have to admit that I would have uninstalled IP.Chat before the upgrade if I knew this would happen. It might have prevented this error.

Share this post


Link to post
Share on other sites

Posted

This is not a bug in IPB. If you must be insistent on calling it a "bug" (which it's not - it's a conflict between two identically named applications), then it would be a problem in IP.Chat, NOT IPB.

http://en.wikipedia.org/wiki/Software_bug

A software bug is the common term used to describe an error, flaw, mistake, [url="http://en.wikipedia.org/wiki/Failure"]failure[/url], or [url="http://en.wikipedia.org/wiki/Fault_%28technology%29"]fault[/url] in a [url="http://en.wikipedia.org/wiki/Computer_program"]computer program[/url] or [url="http://en.wikipedia.org/wiki/Software_system"]system[/url] that produces an incorrect or unexpected result, or causes it to behave in unintended ways.



There is no error, flaw, mistake, failure or fault in IPB here. Period. There's really not any room to debate this. :unsure: IPB works fine.


We have a released supported chat application (that allows for integration with parachat and/or addonchat). We have a new beta chat application that you are free to beta test if you wish. HOWEVER, this new chat application has the same key as the existing one, so if you don't pay attention you can cause a conflict with the chat applications.

This is unrelated to IPB itself.

Share this post


Link to post
Share on other sites

Posted

Brandon, I understand your frustration but when the upgrade affects any user from uninstalling the Chat Services re-installation, then it is a bug that originated from the upgrade. While it may not affect IP.Board, it effectively renders every Administrator impotent where it concerns the removal of the "Chat Services" application.

This is currently the contention.

Fórum Jurídico likes this

Share this post


Link to post
Share on other sites

Posted

I don't think anyone is suggesting that it will continue to be this way when IP.Chat is final. The report was marked not a bug because it's not an IPB bug, but the behaviour will be changed.
As I say, we can't break supported functionality (Parachat and Sigmachat integration) - but when IP.Chat replaces them, it won't be an issue.

So basically: relax ;)
To fix the problem, simply repeat the installation process for IP.Chat.

Share this post


Link to post
Share on other sites

Posted

Mark, you don't understand. IP.Chat simply cannot be reinstalled because "Chat Services" has been reinstalled. IP.Chat cannot be reinstalled because "Chat Services" cannot be uninstalled. Many of us are getting Database Driver error messages when we attempt to do so. Simply reinstalling IP.Chat as it stands now would not work because the other "Chat Services" are interfering with the IP.Chat service.

:blush:

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.