Bugs in the Translations-feature

87 posts in this topic

Posted

And when you will fix the "outdated" and "untranslated" areas, Alex? :cry:

If you ask me, "outdated" should be removed, absolutly useless if after a upgrade of the Software all strings are "outdated" and i have to edit every string two times to remove it from the "outdated count" (but still not from the list of outdated strings).

And: What exactly should the "outdated" strings show? (Old) strings which are not in use?

Share this post


Link to post
Share on other sites

Posted

I wish there was an information script which could notify us that Members tab includes new strings that changed , removed or added. I don't wish to start from Zero everytime when a new board has just released.

In this current Translation program, even if you write a new thing or adding some english words in the right side of your Translation Text , when clicking the "Untranslated words" this will always show the same "english" words.

Untranslated words for me it's not only the words that haven't been changing from English to a different language. It's only the sections where there is a blank field I had to fill-in.

If the board can identify the changed text automatically from the root english language pack on IPS Forums then it should be displayed next to the option "Untranslated text" as "Changed strings".

Is that possible to do it?

Share this post


Link to post
Share on other sites

Posted


And when you will fix the "outdated" and "untranslated" areas, Alex? :cry:



If you ask me, "outdated" should be removed, absolutly useless if after a upgrade of the Software all strings are "outdated" and i have to edit every string two times to remove it from the "outdated count" (but still not from the list of outdated strings).



And: What exactly should the "outdated" strings show? (Old) strings which are not in use?




Assuming this tool works similarly to the ACP (and my understanding is it does), "outdated" strings are strings that were translated from an earlier version of IP.Board. e.g.

IP.Board 3.1.4 has a key "some_key" and the string is "Something". You translate that string to "Something else". You upgrade to IP.Board 3.2. The "outdated strings" will show that language string, because the version it was translated against was an older version. It does *not* track whether the original string changed or not, so it does not inherently mean the translation is no longer correct - just that the last time it was translated was on a previous version.
IPBSupport.de likes this

Share this post


Link to post
Share on other sites

Posted

Assuming this tool works similarly to the ACP (and my understanding is it does), "


No, thats nor working correctly. If you edit a "outdated" string from "something else" to "something else 2" and back to "something else" the number of outdated strings changed, but the string always show as outdated in the translation app. Also we have no "pages" on the "outdated" page.

We also need a option to mark all strings "not" outdated OR, and this would be mutch better, a REAL outdated feature which show us only CHANGED strings. We cannot go threw the complete language strings from version to version when the "outdated" strings not showing "changed" strings (=useless).

IP.Board 3.1.4 has a key "some_key" and the string is "Something". You translate that string to "Something else". You upgrade to IP.Board 3.2. The "outdated strings" will show that language string, because the version it was translated against was an older version. It does *not* track whether the original string changed or not, so it does not inherently mean the translation is no longer correct - just that the last time it was translated was on a previous version.



Okay, thank you - but i still think this feature is useless.

Share this post


Link to post
Share on other sites

Posted


No, thats nor working correctly. If you edit a "outdated" string from "something else" to "something else 2" and back to "something else" the number of outdated strings changed, but the string always show as outdated in the translation app. Also we have no "pages" on the "outdated" page.





That's because it's still edited - the backend does not check to see if you changed it back to what it was originally.


At the end of the day if you find the feature "useless", don't use it. :)

Share this post


Link to post
Share on other sites

Posted

That's because it's still edited - the backend does not check to see if you changed it back to what it was originally.



Sorry, but i think you dont understand what i mean, brandon (and/or I have not explained it properly, sorry).

If we click on a "Outdated Text" link (e.g. THIS link) it SHOULD show all outdated strings (should show 911 strings) but it only show one page (or less) and no page navigation, no option to save strings or something else (only if you edit something).

Maybe you can explain how we can (simple and fast) update strings so they are not show as "outdated". Saving the page/string and/or change a string only reduced the number of outdated strings on the overview, but the string still show under the "Outdated Text" list.

Either the number of outdated strings should not change if you change a string OR the string should be removed from the list of outdated strings...

AND, if a string is outdated, the number of translated strings should not reduced (at the moment "0% completion" show for the gallery app where all strings are outdated). Outdated is not untranslated.

And again: Why we should use the "Outdated" feature when the feature not show changed and only translated strings which translated in a previous version? I see no help or something else in this function for translators. Only a (useless) information.

Share this post


Link to post
Share on other sites

Posted

For some reason, this is still showing the X symbols

×××× / ××צ×

Did you see the last image when I reported on an error with the English text in the left side? then it is now displaying the same issue with Hebrew.

%7Boption%7D

Now the text in the textarea (where we can edit the translation to our language) is not displaying as intended, it displays a symbols as I stated above.

In addition:

The pagination is not working as intended in this Translation Program. It does not show up with a 'jump to page' button or display an option to move to a different page. (using Windows 7 , IE8/IE9/FireFox 4).

Untranslated identifies the "%s" as an untranslated text, why? is that possible to filter this symbol and make it "neutral" and if there will be a word like

The %s's Blog

Then it will show up with an untranslated text message - if it's really has to be updated.

But if it comes alone (for e.g.)

%s

Then, it will be identified as "Translated" 'cause there is nothing to update with %s word.

Share this post


Link to post
Share on other sites

Posted


For some reason, this is still showing the X symbols



×™×™×‘× / ייצ×



Did you see the last image when I reported on an error with the English text in the left side? then it is now displaying the same issue with Hebrew.



%7Boption%7D

71mt1c.png' alt='' class='ipsImage' widt

" alt="" class="ipsImage" width="1000" height="430">



Now the text in the textarea (where we can edit the translation to our language) is not displaying as intended, it displays a symbols as I stated above.



In addition:



The pagination is not working as intended in this Translation Program. It does not show up with a 'jump to page' button or display an option to move to a different page. (using Windows 7 , IE8/IE9/FireFox 4).



Untranslated identifies the "%s" as an untranslated text, why? is that possible to filter this symbol and make it "neutral" and if there will be a word like



The %s's Blog



Then it will show up with an untranslated text message - if it's really has to be updated.



But if it comes alone (for e.g.)



%s



Then, it will be identified as "Translated" 'cause there is nothing to update with %s word.




I'm a bit confused by your posts here.. did you redownload after my post because it should have fixed the x symbols on the left.

As for telling it to miss some language strings - it can't really work out if someone needs translating or not. I can certainly put in a check to see if it's just %s, but, are there any language strings that are just %s in the first place? That seems a bit strange..

I'll look at these after Christmas.

Share this post


Link to post
Share on other sites

Posted

I'll look at these after Christmas.


Please also look at my bugs in the posts above. :)

Share this post


Link to post
Share on other sites

Posted


I'm a bit confused by your posts here.. did you redownload after my post because it should have fixed the x symbols on the left.



As for telling it to miss some language strings - it can't really work out if someone needs translating or not. I can certainly put in a check to see if it's just %s, but, are there any language strings that are just %s in the first place? That seems a bit strange..



I'll look at these after Christmas.




I have been reporting on a new bug with the Hebrew Text or anyother language. In the picture I have posted, there's a problem with the
x Symbols. They all have been fixed but now there's something with the Hebrew text next to the english characters. I didn't want to make
a new Print Screen 'cause I thought you can understand what I am reporting about.

The section of the custom text (where you can translate the english to your own language) is creating X symbols.
Open a new Demo Board and upload language.xml.gz of the Hebrew language pack, then see what happens there.

Login to AdminCP > Manage Languages and try to look for any custom word in Hebrew, you won't find anything in the manage language
'cause everything has just switched to "x" symbols. (when it would need to display the hebrew as was needed).

Share this post


Link to post
Share on other sites

Posted

Okay Jean, can you try one more time, it was exporting it as an incorrect charset on our install here.. hence the x's, this should be sorted now though! :)

Share this post


Link to post
Share on other sites

Posted

Do you ignore me, alex? :cry:

Share this post


Link to post
Share on other sites

Posted


Do you ignore me, alex? :cry:




My post is directed to Jean's bug report which is a high priority due to the export function not working. Your concerns will be looked at shortly.
IPBSupport.de likes this

Share this post


Link to post
Share on other sites

Posted

And my concerns, who started this topic, I hope ;)

Alex likes this

Share this post


Link to post
Share on other sites

Posted

92% completion in Hebrew but it's not the correct information.
Look at this page:
http://community.invisionpower.com/index.php?app=languages&module=products&section=language&language=11
System Tab notes 98% completion but doesn't have blank strings.
Gallery 0% completion (913 strings out of date)
How? Gallery has some new strings that I don't even know what they are?

Share this post


Link to post
Share on other sites

Posted

@Jean:

I reported this some post above (out of date marked as untranslated, dont know why).

BUT at all, we can look forward to 3.3: Mark marked (lol) this bugtracker entry as fixed, so only changed strings show up as "out of date" and now "out of date" make sense (on 3.3 and maybe also on the translation system here on IPS).

Share this post


Link to post
Share on other sites

Posted

I am sorry. It's bad that we can't really know what was changed in the new version. James Kessler updated us about these news so far, so I can't guess what is going to replace it. May IPS can release a monthly report of all their changes they have done in the new version regarding to the languages packs. (The report included Changed / Removed / Added strings) and even they could make a feature that IPS can do it for all of their languages installed on the server at once.

Share this post


Link to post
Share on other sites

Posted


92% completion in Hebrew but it's not the correct information.


Look at this page:


http://community.inv...age&language=11

System Tab notes 98% completion but doesn't have blank strings.


Gallery 0% completion [color=orange](913 strings out of date)[/color]


How? Gallery has some new strings that I don't even know what they are?




92% is correct then, 92% is an average with System having the biggest effect on that percentage because it has the most strings. Seems the Gallery import went a bit iffy if it's saying they're out of date. I'll see why Gallery is playing up.

As for the 98% completion issue - there are several untranslated strings, we'll get that area sorted ASAP though.

Share this post


Link to post
Share on other sites

Posted

Still waiting for fixes to the language app (untranslated and out of date still not work correctly)

AND: Where is the link to the language system (in the header)?

Share this post


Link to post
Share on other sites

Posted


AND: Where is the link to the language system (in the header)?




As we are testing 3.3 and regularly updating our forum, the skin customization that adds the bar you reference was removed (we had to revert our template) and will be added back in due course.
IPBSupport.de likes this

Share this post


Link to post
Share on other sites

Posted

@ Alex, it hasn't been fixed yet. (out of date strings message display even if they're not out of date strings).

Share this post


Link to post
Share on other sites

Posted

If I'm not mistaken, he had to wait on 3.3 which made some changes to better identify which strings are out of date.

Alex likes this

Share this post


Link to post
Share on other sites

Posted

i don't know if this is the right place to say this things.
i just see the traslation interface, a month or two after the implementation. I'm late, i know.

I just want to say that with this page i will be impossible to do a right traslation. There is no coordination (is there?) and without knowing where a string will be applied there is no way to know which is the right traslation.

Do a pair of examples:

1) the word "post" can be traslated in 2-3 ways depending on who translate.
2) the word "post" in the string is the noun or the verb? How can i know?

So, it's impossible to use this method of traslation to translate a simple language (enghish) in a more complex one.

Other than this, i cannot know if the string will be put in a place with limited space. Knowing that i can use a shorter translation (less clear too).


Thank you.

Share this post


Link to post
Share on other sites

Posted

Tomorrow we are in march and the translation area still dont work correctly (untranslated still not work etc).

I asked this a few times: Should we post the bugs to the tracker?

Share this post


Link to post
Share on other sites

Posted

Why does my language pack have 93%? everything is "100%" completed.
http://community.invisionpower.com/index.php?app=languages&module=products&section=language&language=11
System - 100% completion
Forums - 100% completion
Members - 100% completion
IP.Blog - 100% completion
Downloads - 100% completion
Gallery - 100% completion
Calendar - 100% completion
Chat - 100% completion
Content - 100% completion
IP.Nexus - 100% completion

08 in March since the last post was made by IPBSupport.de and we still don't see that feature work properly.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.